Shopify API Degraded Performance
Incident Report for Violet
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 11:31 PDT
Update
The 500 Internal Server errors from product related endpoints appear to be subsiding.
Posted Aug 29, 2024 - 11:31 PDT
Update
We've implemented a solution for the failed Shopify Draft Order submission. It appears that Shopify introduced a bug into this endpoint, https://shopify.dev/docs/api/admin-rest/2024-07/resources/draftorder#put-draft-orders-draft-order-id-complete, at around 9am PT where submission requests would fail because Shopify could not read the length of the request body. As there is no request body with this endpoint this is likely not intended behavior. The Violet system will now detect this specific error and switch over to using the Write Order endpoint anytime it occurs. Any Draft Order resource will be deleted to ensure that there is no orphaned/abandoned entities in the merchants system. Full retro to follow.
Posted Aug 29, 2024 - 11:26 PDT
Monitoring
We are currently monitoring degraded performance when interacting with the Shopify API. There has been a significant increase in 500 Internal Server Errors returned by the Shopify API when performing product syncs and when performing checkout.
Posted Aug 29, 2024 - 09:15 PDT
This incident affected: Production API, Sandbox API, and Shopify API & Mobile.